$re = '/([^ ]+) ([^ ]+) ([^;]+);(.*?)$/';
$str = 'Фамилия Имя Отчество;7 123-456-78-90';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);