import re
regex = re.compile(r"[ \t]*([\w]+)", flags=re.MULTILINE)
test_str = (" Purchase,\n"
" Dispose,\n"
" DepreciatePurchase,\n"
" DepreciateRevalue,\n"
" DepreciateReversalPurchase,\n"
" DepreciateReversalRevalue,\n"
" Revalue,\n"
" Depreciate,\n"
" DisposeOfRevalue,\n"
" DisposeOfDepreciation,\n"
" DisposeOfRevalueDepreciation,\n"
" UndoDispose,\n"
" UndoDisposeOfRevalue,\n"
" UndoDisposeOfDepreciation,\n"
" UndoDisposeOfRevalueDepreciation,\n"
" UndoSell")
subst = "ActionType.$1 => Proto.ActionType.$1"
result = regex.sub(subst, test_str)
if result:
print(result)