$re = '/^\h*[][]\h*$/m';
$str = ' [
[
[
Test
Server1
Server2
stopped
]
]
]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);