import Foundation
let pattern = #"href=(.*?)&"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"https://www.facebook.com/plugins/video.php?href=https%3A%2F%2Fwww.facebook.com%2Fportateste%2Fvideos%2F1585186298555265%2F&show_text=0&width=560"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)