// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\/\/(?:[^@\/\n]+@)?(?:www\.)?([^:\/\n]+)").unwrap();
let string = "https://play.google.com/store/apps/details?id=com.skgames.trafficracer%22
http://mplay.google.co.in/sadfask/asdkfals?dk=10
http://lplay.google.co.in/sadfask/asdkfals?dk=10
http://play.google.co.in/sadfask/asdkfals?dk=10
http://tplay.google.co.in/sadfask/asdkfals?dk=10
http://www.google.co.in/sadfask/asdkfals?dk=10
www.google.co.in/sadfask/asdkfals?dk=10
http://user:pass@google.com/?a=b#asdd";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}