#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((?:\d,)+)(.*?)\1+|((?:\d,)+)"
Local $sString = "1,2,3,4,1,2,3,4,5,6,5,6,5,6," & @CRLF & _
"2,3,1,2,3,1,1,2,3,4," & @CRLF & _
"2,3,1,1,2,3,4,2,3,1,"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")