$re = '/\bbla$/';
$str = 'the brown fox jump bla
over the Lazy
dog ..Bla bla bla';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);