$re = '/(\d)\1{2}(*SKIP)(*F)|(\d)\2/m';
$str = '123456678
12334566
1234566678
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);