// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ui)(?|(e)(pisodes?)|(c)(hapters?)|(c)(hs?)|(e)(ps?)|(c)(s?)|(e)(s?)|()())\s*((\d+(?:\.\d+)?(?:[A-Z]\b)?)(?:\s*(?:[,&+-]|and)\s*(?:(?:e(?:pisodes?)|c(?:hapters?)|c(?:hs?)|e(?:ps?)|c(?:s?)|e(?:s?)|)\s*)?(?4))*)").unwrap();
let string = "chapter 2A Hello
chapter 2AHello
text chapter 25.6 text
// c~25.6
text chapters 23, 24, 25 text
// c~23-25
text chapter 23, 25 text
// c~23 & 25
text chapter 23 & 24 & 25 text
// c~23-25
text c25.5-30 text
// c~25.5-30
text c99-c102 text
// c~99-102
text chapter 1 - 3 text
// c~1-3
33 text chapter 1, 2 text 3
// c~1-2
chapter 25.6 & chapter 29
// c~25.6 & 29
chapter 25+c26
// c~25-26
chapter 25 + 26 + 27
// c~25-27
chapter 10.4C
= c~10.4 part 3
chapter 2B
= c~2 part 2";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}