const regex = new RegExp('[0-9]+A Line[0-9]+(?: \\w+)+?(?= [0-9]+A Line[0-9]+|$)', 'gim')
const str = `1A Line1 Detail1 Detail2 Detail3 2A Line2 Detail 3A Line3 Detail Detail`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}