import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?x)(?:^|\\s|\\G|[\\(\\[\\{])(\\*\\*|__)(?=\\S)(?=(<[^>]*+>| (?<raw>`+)([^`]|(?!(?<!`)\\k<raw>(?!`))`)*+\\k<raw>|\\\\[\\\\`*_\\{\\}\\[\\]()#.!+\\->]?+| \\[((?<square>[^\\[\\]\\\\]| \\\\.| \\[ \\g<square>*+ \\])*+\\](([ ]?\\[[^\\]]*+\\])| (\\([ \\t]*+<?(.*?)>?[ \\t]*+((?<title>['\"])(.*?)\\k<title>)?\\))))|(?!(?<=\\S)\\1).)++(?<=\\S)\\1)";
final String string = "I like bold (**like this**).";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}