package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[^\W_]|[ '-])+$`)
var str = `abcd ßloc ådam
-123 ' Þß`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}