using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(\w+)\s+\1\b";
string input = @"word1 word1 word1 word word3 wordesd sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1
word1 word1 word1 word word3 wordsd sdfsdf dsf sword1 word2 word2 word1 sdfswdf safsdfsdf word1
word1 word1 word1 word word3 wordsd sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1
word1 word1 word1 word word3 wordsd sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1
word1 word1 word1 word word3 wordsdr sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1
word1 word1 word1 word word3 wordsd sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1
word1 word1 word1 word word3 wordsd sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1
word1 word1 word1 word word3 wordsd sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1
word1 word1 word1 word rword3 wordsd rsdfsdf dsf sword1 words2 word2 word1 sdfsdf safsdfsdf word1
word1 word1 word1 word word3 wordsd sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1
word1 word1 word1 word word3 wordsd sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1
word1 word1 word1 word word3 wordsd sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1
word1 word1 word1 word word3 wordsd sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1
word1 word1 word1 word word3 wordsd rsdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1
word1 word1 word1 word word3 wordsd sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1
word1 word1 word1 word wored3 wordsd sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1
word1 word1 word1 word wordr3 wordsd sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1
word1 word1 word1 word word3 wordsd sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1
word1 word1 word1 word word3 wordsd sdfsdf dsf sword1 word2 word2 woerd1 sdfsdf safsdfsdf word1
word1 word1 word1 word word3 wordsd sdfsdf dsf sword1 word2 word2 word1 sdfsdf safsdfsdf word1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}