$re = '/Hello\smy\sname\sis\s(?:(?!\bjohn\b).)*?\sand\sI\slike\spizza/';
$str = 'Heloo my name is abcd, and I like pizza
Hello my name is asdf, and I like pizza
Hello my name is john, and I like pizza';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);