$re = '/^\d{4}(-{1}\d{4})?/m';
$str = '1234
1234-5678
12345678
123-456
1234-';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);