import re
regex = re.compile(r"^(?:::f{4,6}:)?(?P<host>\S+) .* \"(GET|POST) [^\"]+\" 403", flags=re.MULTILINE)
test_str = ("112.253.6.182 - - [08/Sep/2014:17:42:56 -0400] \"GET / HTTP/1.1\" 403 579 \"baidu\" \"Mozilla/4.0\"\n"
"106.37.177.251 - - [08/Sep/2014:17:42:56 -0400] \"GET /index.php HTTP/1.1\" 404 576 \"baidu\" \"Mozilla/4.0\" \n"
"204.44.65.173 - - [08/Sep/2014:17:42:56 -0400] \"GET /index.php HTTP/1.1\" 404 576 \"baidu\" \"Mozilla/4.0\" \n"
"204.44.65.173 - - [08/Sep/2014:17:42:56 -0400] \"GET / HTTP/1.1\" 403 579 \"baidu\" \"Mozilla/4.0\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")