package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^#\s(?P<header>(\w+='\w+')(,\s*(\w+='\w+'))*)$`)
var str = `# type='baseline', project='IHU', customer='VCC', release='IP605', buildnr='12'
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}