re = /(^\{?[A-Z0-9]{8}-[A-Z0-9]{4}-[A-Z0-9]{4}-[A-Z0-9]{4}-[A-Z0-9]{12}\}?)$/i
str = 'A98C5A1E-Aa42-4808-9SfA-6F409E799937'
# Print the match result
str.match(re) do |match|
puts match.to_s
end