import re
regex = re.compile(r"<span style[^>]</span>", flags=re.MULTILINE)
test_str = "\"<p>Sau khi đã tốn nhiều giấy mực cho thương vụ Benzema tới London, báo chí Anh lại đang chuyển chủ để sang một cái tên khác là Edison Cavani khi đang có những dấu hiệu cho thấy, HLV Arsene Wenger đang muốn chiêu mộ chân sút thuộc ‘hàng khủng’ này trước khi thị trường chuyển nhượng năm nay đóng cửa vào ngày thứ Ba tới.<\\/p> <p style=\\\"text-align: center;\\\"><a href=\\\"http:\\/\\/admin.thethao247.vn\\/files\\/2\\/86\\/cavani.jpg\\\"><img src=\\\"http:\\/\\/admin.thethao247.vn\\/files\\/2\\/86\\/cavani.jpg\\\" \\/><\\/a><\\/p> <p style=\\\"text-align: center;\\\"><span style=\\\"color: #0000ff;\\\">Cavani có thể sang London<\\/span><\\/p> <p>Trước đó, tiền đạo Real Madrid Karim Benzema đã xóa tan các tin đồn sau khi lên tiếng sẽ ở lại sân Bernabeu trong mùa giải này. Việc trung phong người Pháp cam kết ở lại Tây Ban Nha khiến Giáo sư Wenger buộc phải hướng tầm ngắm sang tiền đạo đang khoác áo PSG Cavani cho những kế hoạch dài hơi của Arsenal trong thời gian sắp tới.<\\/p> <p>Ở độ tuổi sung sức của sự nghiệp, Cavani đang là mục tiêu theo đuổi của cả Arsenal và Man United khi những tiền đạo trên hàng công của họ chưa cho thấy sự hiệu quả ở mùa giải này. Sau nhiều năm ‘thắt lung buộc bụng’ HLV Wenger cũng đang cho thấy mình không hề thua kém các đồng nghiệp khi đã bỏ ra 42 triệu cho Mesut Ozil hay 35 triệu bảng để có được Sanchez. Điều đó cho thấy thương vụ Cavani tới Arsenal là vẫn còn và NHM Pháo thủ vẫn có thể hi vọng vào bản hợp đồng này.<\\/p> <p>Một tin đồn khác là việc Arsenal đang ‘rất kết’ tiền đạo Aleksandr Kokorin của Dynamo Moscow. Anh cũng là mục tiêu mà HLV Van Gaal theo đuổi nhưng có vẻ tuyển thủ người Nga sẽ đầu quân cho nhà vô địch Ligue 1 PSG dù đại diện đội bóng Pháp và phía đối tác Nga chưa xác nhận về điều này.<\\/p> <p>Liên quan tới vấn đề nhân sự của Pháo thủ, một tin không vui là hậu vệ chủ chốt của họ, Laurent Koscielny đã không may gặp phải chấn thương và sẽ lỡ hẹn cùng đồng đội đến làm khách tại sân St James Park của Newcastle ở trận đấu sớm vòng 4 Premier League ngày thứ Bảy tới.<\\/p> <p style=\\\"text-align: center;\\\"><a href=\\\"http:\\/\\/admin.thethao247.vn\\/files\\/2\\/86\\/Kos_mert_3418732b_1.jpg\\\"><img src=\\\"http:\\/\\/admin.thethao247.vn\\/files\\/2\\/86\\/Kos_mert_3418732b_1.jpg\\\" \\/><\\/a><\\/p> <p style=\\\"text-align: center;\\\"><span style=\\\"color: #0000ff;\\\">Per-Laurent là bộ đôi trung vệ tin cậy nhất của Pháo thủ Arsenal lúc này<\\/span><\\/p> <p>Hậu vệ tuyển Pháp đã dính chấn thương lưng và không thể góp mặt cùng đồng đội ở trận hòa không bàn thắng của Arsenal trước Liverpool, trong khi đó trung vệ Per Mertesacker cũng gặp phải vấn đề sức khỏe nhưng hoàn toàn có thể quay lại vào cuối tuần này. Ở trận đấu hôm thứ Hai (24\\/8), lần đầu tiên kể từ tháng Tư năm 2012, Pháo thủ không có sự xuất hiện của bộ đôi Per-Laurent trong một trận đấu. Việc sạch lưới của Arsenal ở vòng Ba phải kể tới sự xuất sắc của thủ môn Petr Cech hơn là độ vững chãi nơi hàng hậu vệ, khi mà họ đang dồn toàn lực cho sự xuất hiện của một tiền đạo mới. Chắc chắn trong trận đấu sắp tới, hàng thủ Arsenal sẽ là điều mà Giáo sư Wenger lo ngại nhất sau sự thiếu vắng của những cái tên này.<\\/p>\""
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")