package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d*)(\D*)\s*(\d*)`)
var str = `ICU24`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}