package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`RT @(\w+):`)
var str = `RT @ReutersAero: Further pictures from the #MH17 crash site in in Grabovo, #Ukraine #MH17 - @reuterspictures (GRAPHIC): http://t.co/4rc7Y4…
RT @AnotherAero: Further pictures from the #MH17 crash site in in Grabovo, #Ukraine #MH17 - @reuterspictures (GRAPHIC): http://t.co/4rc7Y4…
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}