package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[ ]*(.*?)[ ]*$`)
var str = ` This line is trimed `
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}