const regex = new RegExp('(?<!\\.)([\\r\\n]+)\\s*([A-Z])', 'gm')
const str = `The Cat
Now is the time for the quick
brown cat to jump over.`;
const subst = `.\1\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);