# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^$"
test_str = ("//SHOULD\n"
"0\n"
"3\n"
"6\n"
"9\n"
"18\n"
"24\n"
"30\n"
"48\n"
"51\n"
"69\n"
"72\n"
"81\n"
"96\n\n"
"//NOT\n"
"1\n"
"2\n"
"4\n"
"5\n"
"7\n"
"8\n"
"10\n"
"11\n"
"13\n"
"14\n"
"16\n"
"20\n"
"22\n"
"23\n"
"25\n"
"26\n"
"100\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.