$re = '/^(?=.*(?<subtagcha>_*CHA_+))(?=.*(?<subtaglog>_*LOG_*))(?=.*(?<subtagtag>_*TAG_*)).*/m';
$str = '///////////////////////////////////////////////////////////////////
//
// UPDATE NOTES FILE
//
// CHANGES LOG TAG :
//
// CHA LOG TAG :
//
// CHA TAG_LOG :
//
// ___CHA_LOG_2025_1122_TAG_V01 //
//
// CHA_LOG_2025_1122_TAG_V01 //
//
// CHA_LOG_2025_TAG_1122_TAG_V01 //
//
// CHA_LOG_2025_TAG_1122_V01 //
//
// CHA_TAG_LOG_2025_1122_V01 //
//
// CHA_LOG_2025_TAG //
//
///////////////////////////////////////////////////////////////////
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);