$re = '/\b(?!product)\b\S+/m';
$str = '/product/something
https://www.domain.com/product/something
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);