using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*)[[:space:]]\[TYPE\]=E[[:space:]]\[MSG\][[:space:]](.*)$";
string input = @"[TIME]=2022/03/29 08:01:47
[TYPE]=E
[MSG]
Machine : WS-A01, Module: CTS RequestProcessing, generation Time :Tue Mar 29 08:57:47 XYZ 2022, Message :Long Processing Time: 2036 ms-MessageType: ABC EFG LOOKS LIKE A SYSTEM ERROR-GId: 2341-RequestId: WS-A01~REPORT~1234b14d72e912:2437ce83
[ACTION]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}