$re = '/(?<=(?<!\S)\d+\.\s(?:\s\d+\.\s)*)[^\s.,:!?]+/m';
$str = '1. text
2. wordX wordY.
3. 4. wordZ.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);