import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<Fname>.*\\.)(S(?<se>\\d{1,2})E(?<ep>\\d{2,3}).*|(?<yr>\\d{4}[^p]).*)";
final String string = "Westworld.S04E05.720p.WEB.h264-KOGi[rarbg]\n"
+ "Westworld.S04E04.1080p.WEB.H264-CAKES[rarbg]\n"
+ "For.All.Mankind.S03E08.720p.WEB.h264-KOGi[rarbg]\n"
+ "Talk.to.Me.2022.1080p.WEBRip.DD5.1.x264-LAMA\n"
+ "Jules.2023.1080p.AMZN.WEBRip.DD5.1.x264-LAMA\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}