package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\P{L}*`)
var str = `\$5ı龢abc`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}