import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+:\\d+\\D*(?:\\d(?!\\d*:\\d)\\D*)*";
final String string = "1:1 wefeff qwefejä qwefjk\n"
+ "dfjdf 10:2 jdskjdksdjö\n"
+ "12:1 qwe qwe: qwertyå";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}