# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<![-\w])\d{8,12}(?![-\w])"
test_str = ("e5655558888\n"
"r666666\n"
"t 5987442510\n"
"j69698888885\n"
"U 568457562388 11255525h555h4 4444444444444444 5655555/85 55555-555-23-23 55 This next section I do NOT want to be captured 636363666-66-12345678\n"
"I56588895620\n"
"56854444002 this number can be anywhere in the sentence ike this: 123456789 Or it could just be like this 98765432 these are good\n"
"but it should NOT find this 050860404-01e0-4a5a-b8db-a97f26a668ac\n"
"p 63666900000\n"
"bank account 12356895555\n"
"123456780000\n"
"2222\n"
"05086040\n"
"Not sure what the plan might be thought for when i have a sentence with account information for my checking account written in a document like this, here is the savings account number 1234567890. thank you. overdraft 9876543210")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.