$re = '/\b(?<!abc:)\d{7}\b/m';
$str = 'abc:1234567,cd:2345678,efg:3456789012';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);