// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?xs).*?
(
<div\ id="content"
.+?
)
<div\ id="footer
"#).unwrap();
let string = "hello this is some text I don't want
asdf
asdfasd
ff
<div id=\"content\" class=\"other\">
i have this other stuff
<div>More stuff</div>
<div id=\"footer>
hello^[^_]*_
asd;flkjasd
f;kas
dfas
df
asdf a2 5<div id=\"footer\"><div id=\"content></div>";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}