import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:<TYPE>(?<type>.*?)<\\/TYPE>)|(?:<NAME>(?<name>.*?)<\\/NAME>)|(?:<ARTIST>(?<artist>.*?)<\\/ARTIST>)|(?:<DURATION>(?<duration>.*?)<\\/DURATION>)";
final String string = "<?xml version=\"1.0\" encoding=\"windows-1251\" ?><ELEM_LIST><ELEM PLAYER_NAME=\"Плеер\" STATUS=\"playing\"><START_TIME>15:49:41</START_TIME><BLK_TYPE>М</BLK_TYPE><TYPE>М</TYPE><NAME>Heathens</NAME><ARTIST>Twenty One Pilots</ARTIST><AUTHOR></AUTHOR><ALBUM></ALBUM><DBID></DBID><FILE_NAME>H:\\Radio\\Music\\Twenty One Pilots - Heathens.mp3</FILE_NAME><DURATION>00:03:10</DURATION></ELEM><ELEM PLAYER_NAME=\"Плеер\" STATUS=\"preloaded\"><START_TIME></START_TIME><BLK_TYPE>М</BLK_TYPE><TYPE>Д</TYPE><NAME>ID #5</NAME><ARTIST>Jingle</ARTIST><AUTHOR></AUTHOR><ALBUM></ALBUM><DBID></DBID><FILE_NAME>H:\\Radio\\Jingle's\\ID #5.mp3</FILE_NAME><DURATION>00:00:01</DURATION></ELEM><ELEM PLAYER_NAME=\"Плеер\" STATUS=\"preloaded\"><START_TIME></START_TI) ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}