import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bQuestion\\s\\d+\\s+(\\S.*?)\\s+Answer\\s+\\d+\\s+(\\S.*?)\\s*(?=Question|$)";
final String string = "Question 1 What is the weather today? Answer 1 It is hot and sunny. Question 2 What day is it today? Answer 2 Thursday Question 3 How many legs does a dog have? Answer 3 Four legs";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}