using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<Element_Name>[a-zA-Z].*[a-zA-Z]+).*?(?P<first_price>\d+,\d+)(?:[^\d\n]*(?P<sec_price>\d+,\d+))?";
string input = @"Total 123,11
TEST TEST 313131231 132,131 31231,3123 <--- add 313131231 into new group
TEST TEST TEST 12313 123,123 <--- add 12313 into new group
TEST 1 1231,4123 <--- add 1 into new group
TEST 131234,211 <--- do not add empty string into new group
TEST 78
TEST 3 2,13 <--- add 3 into new group";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}