$re = '~https?://\K[^/]+~m';
$str = 'http://РАНДОМНЫЙ-ДОМЕН/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);