package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(,[0-9]{7}[0-9A-F]{8})+`)
var str = `C7,22801422CFE0F63,2280141C5EF0F63,22801402EFD0F63,2280138C5ED0F63,228024329897530,228023829877530`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}