using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[.+,(.+),.+\]";
string input = @"2021-03-01 11:43:07.689 INFO [boot-otel-tempo-provider1,24b65cc591d3a69da10f308ab41343d7,6db7a6a82703fee9] 8 --- [nio-8090-exec-5] i.o.example.flight.FlightService : Doing some work In New span ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}