$re = '/[a-zA-Z0-9]{2}(?=[ -])/m';
$str = 'AA-1234;UA 243;EK 23;
9W 23;B6-134';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);