import Foundation
let pattern = #"^((?:[sp][0,1][0-9]|downloads)\.upd)(?(1)\.kaspersky\.com)|(?:cm\.k|downloads)\.kaspersky-labs\.com$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
cm.k.kaspersky-labs.com
downloads.kaspersky-labs.com
downloads.upd.kaspersky.com
s00.upd.kaspersky.com
s01.upd.kaspersky.com
s02.upd.kaspersky.com
s03.upd.kaspersky.com
s04.upd.kaspersky.com
s05.upd.kaspersky.com
s06.upd.kaspersky.com
s07.upd.kaspersky.com
s08.upd.kaspersky.com
s09.upd.kaspersky.com
s10.upd.kaspersky.com
s11.upd.kaspersky.com
s12.upd.kaspersky.com
s13.upd.kaspersky.com
s14.upd.kaspersky.com
s15.upd.kaspersky.com
s16.upd.kaspersky.com
s17.upd.kaspersky.com
s18.upd.kaspersky.com
s19.upd.kaspersky.com
p00.upd.kaspersky.com
p01.upd.kaspersky.com
p02.upd.kaspersky.com
p03.upd.kaspersky.com
p04.upd.kaspersky.com
p05.upd.kaspersky.com
p06.upd.kaspersky.com
p07.upd.kaspersky.com
p08.upd.kaspersky.com
p09.upd.kaspersky.com
p10.upd.kaspersky.com
p11.upd.kaspersky.com
p12.upd.kaspersky.com
p13.upd.kaspersky.com
p14.upd.kaspersky.com
p15.upd.kaspersky.com
p16.upd.kaspersky.com
p17.upd.kaspersky.com
p18.upd.kaspersky.com
p19.upd.kaspersky.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)