using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.{3,50}$)[A-Za-zÀ-ÿ]+\s[A-Za-zÀ-ÿ]+$";
string input = @"Aÿ
A ÿ
Add ÿ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}