#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "<h1>([^<]*)<\/h1>\s*\n([\w\W]*?)(([^\n\S]*)<td\s.*?<\/td>(\n))(?=\s*<\/tr>)|(?<=<h1>([^<]*)<\/h1>[\w\W]*?)(([^\n\S]*)<td\s.*?<\/td>(\n))(?=\s*<\/tr>)"
Local $sString = "<h1>TITLE OF HEAD 1</h1>" & @CRLF & _
"<table>" & @CRLF & _
" <tbody>" & @CRLF & _
" <tr>" & @CRLF & _
" <td class="one">ITEM 1, AFTER HEAD 1</td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td class="one">ITEM 2, AFTER HEAD 1</td>" & @CRLF & _
" </tr>" & @CRLF & _
" </tbody>" & @CRLF & _
"</table>" & @CRLF & _
"<table>" & @CRLF & _
" <tbody>" & @CRLF & _
" <tr>" & @CRLF & _
" <td class="one">ITEM 3, AFTER HEAD 1</td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td class="one">ITEM 4, AFTER HEAD 1</td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td class="one">ITEM 5, AFTER HEAD 1</td>" & @CRLF & _
" </tr>" & @CRLF & _
" </tbody>" & @CRLF & _
"</table>" & @CRLF & _
"<h1>TITLE OF HEAD 2</h1>" & @CRLF & _
"<table>" & @CRLF & _
" <tbody>" & @CRLF & _
" <tr>" & @CRLF & _
" <td class="one">ITEM 6, AFTER HEAD 2</td>" & @CRLF & _
" </tr>" & @CRLF & _
" </tbody>" & @CRLF & _
"</table>" & @CRLF & _
"<h1>TITLE OF HEAD 3</h1>" & @CRLF & _
"<table>" & @CRLF & _
" <tbody>" & @CRLF & _
" <tr>" & @CRLF & _
" <td class="one">ITEM 7, AFTER HEAD 3</td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td class="one">ITEM 8, AFTER HEAD 3</td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td class="one">ITEM 9, AFTER HEAD 3</td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td class="one">ITEM 10, AFTER HEAD 3</td>" & @CRLF & _
" </tr>" & @CRLF & _
" </tbody>" & @CRLF & _
"</table>" & @CRLF & _
"<h1>TITLE OF HEAD 4</h1>" & @CRLF & _
"<table>" & @CRLF & _
" <tbody>" & @CRLF & _
" <tr>" & @CRLF & _
" <td class="one">ITEM 11, AFTER HEAD 4</td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td class="one">ITEM 12, AFTER HEAD 4</td>" & @CRLF & _
" </tr>" & @CRLF & _
" </tbody>" & @CRLF & _
"</table>" & @CRLF & _
""
Local $sSubst = "$2$3$4$7$8<td class="two">$1$6</td>$5$9"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)