const regex = new RegExp('^[\\s]{0,2}\\[([\\d]*)\\]:', 'gm')
const str = `---
# Meta Data
Title: Test Set for Mark Down Reference Linking
Summary: Test Set for Mark Down Reference Linking
Author: Royi
# Settings
settings:
enable_uml: true
image_path_conversion: base64
markdown_extensions:
- markdown.extensions.footnotes
- markdown.extensions.fenced_code
- markdown.extensions.tables
- markdown.extensions.admonition
- markdown.extensions.toc:
title: Table of Contents
toc_depth: 2-3
- pymdownx.arithmatex:
generic: true
smart_dollar: false
allow_css_overrides: true
---
# Test Set for Mark Down Reference Linking
[TOC]
## Scope of the Document
Just some text as a test set.
### Some ASCII Graphics
Laser beam.
\`\`\`
Target
+--------------------------------+
| |
| |
| |
| |
| -- |
| -/ |
| --/ |
| -/ |
| --/ |
+--------------------------------+
-/
--/
<-------------------/----------------------->
--/
-/
--/
+--------/
| -/|
| -/ |
| | Laser Beam
+------+
\`\`\`
## Some List
* Train Set - Set used for training the ML model (For instance optimize the model parameters [For Parametric Model])
* Test Set - Set used to evaluate results.
* Prediction - Prediction of velocity given a measurement.
Implicit / Explicit Assumptions[^001]:
* The laser beam is eye safe.
* Just some information[^002].
### Some Existing Links
The results are pretty good in [RMSE][001] / [MAE][002].
## Some Text to Test
Free text, **bold text**, *italic text*, [__bold text__][003] or _italic text_.
Also, \`Mono Spaced Text\` and regular [boring text][04].
Some [Link](https://www.wikipedia.com) and [Reference Link][1].
Some list...
* Examining Deep Learning (DL) Based Methods
Always some text on [Deep][1] Learning.
* Hyper Parameters
Adding an exhaustive search of the optimal Hyper Parameters.
[001]: https://en.wikipedia.org/wiki/Root-mean-square_deviation "Wikipedia - RMSE"
[002]: https://en.wikipedia.org/wiki/Mean_absolute_error "Wikipedia - MAE"
[003]: https://something.com
[04]: https://somewhere.com
[5]: Should not be selected!
[6]: Should not be selected!
[^001]: Just a simple assumption reference.
[^002]: Just another simple assumption reference.
[1]: https://www.wikipedia.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}