$re = '/(?=.*\b(?:error|alarm)\b).*/m';
$str = 'ns1.alarm.abc
ns2.error.cdb';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);