$re = '/mas (.+)/m';
$str = 'I like birds
I mas like birds
I like mas birds';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);