re = /(?<=--name \")[^\"]+|(?<=--folderName \")[^\"]+/m
str = '--name "name" --folderName "folderName"
--folderName "folderName" --name "name"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end