import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?|([A-Z]\\w+ [A-Z]\\w+)(?:\\w* )*([a-zA-Z0-9._%+-]+@[a-zA-Z0-9.-]+\\.[a-zA-Z]{2,4})|([a-zA-Z0-9._%+-]+@[a-zA-Z0-9.-]+\\.[a-zA-Z]{2,4})(?:\\w* )*([A-Z]\\w+ [A-Z]\\w+)|([a-zA-Z0-9._%+-]+@[a-zA-Z0-9.-]+\\.[a-zA-Z]{2,4}))";
final String string = "John Doe john@doe.com random text\n"
+ "Jane Doe random text jane@doe.com\n"
+ "jim@doe.com more random text tim@doe.com Tim Doe\n"
+ "tex@doe.com Tex Doe\n\n"
+ "D'arcy Bly Markus-Anthony Reid Lee Z abc@test.com";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}