import Foundation
let pattern = #"<script\b[^<]*(?:(?!<\/script>)<[^<]*)*<\/script\s*>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
So, let’s imagine that we have to check a text field, and there’s no particular information about it in project specifications.
In this case, it’s possible to do the following:
Click on the Submit button without previous text field filling.
Click on the space bar a few times, and then click on the Submit button.
Analyze how many characters you can enter in the field, and then press the Submit button.
Enter the minus sign and as many numbers as you can, and then tap Submit.
Enter all the possible special symbols and click Submit. If you see a message with an error, try to analyze it.
Try to enter the symbols that don’t technically correspond with ASCII, different emoji icons, and click Submit. If you see a message with an error, try to analyze it.
Try the features of the cross-site scripting. For this, you should enter such a script: <SCRIPT>alert(“I hacked this!”)</SCRIPT>. If there is a pop-up after clicking Submit, it means that this field is vulnerable to XSS attack (cross-site scripting attack).
Check if it’s possible to use SQL injections. Enter FOO’); DROP TABLE USERS. But don’t do this with databases of those sites that are in production.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)